Now supporting Python 3.8 and latest matplotlib version


Daniel Huppmann
 

Dear pyam user community,

We implemented a number improvements last week so that pyam is now fully compatible with Python 3.8 and the latest version of matplotlib! This is not yet included in a release (to identify any potential issues that weren’t caught by the tests over the next weeks), but you can check-out the GitHub repository and install locally. Please create an issue if this does not work as expected.

Also, we are in the process of migrating our continuous integration suite from specific tools (travis, appveyor, stickler) to GitHub Actions - this allows to test all operating systems and several Python versions in a more streamlined, efficient manner.

Best regards,
Daniel

--

Dr. Daniel Huppmann
Research Scholar, Energy Program (ENE)

International Institute for Applied Systems Analysis (IIASA)
Schlossplatz 1, A-2361 Laxenburg, Austria
huppmann@...
+43(0) 2236 807-572
www.iiasa.ac.at/staff/huppmann